nixos-config/modules/base.nix

24 lines
641 B
Nix

{ config, lib, ... }:
{
options.ptw.system = {
singleUser = lib.mkOption {
type = lib.types.str;
example = "PapaTutuWawa";
readOnly = true;
description = "The username of this single-user system";
};
wireless = lib.mkEnableOption "Enable wireless functionality";
primaryInterface = lib.mkOption {
type = lib.types.str;
description = "The primary network interface to use";
default = "";
};
hostName = lib.mkOption {
type = lib.types.str;
description = "The hostname to use";
};
isVM = lib.mkEnableOption "Sets whether the treat the host as VM";
};
}