blog.polynom.me/flake.nix
Alexander "PapaTutuWawa caef031d48
All checks were successful
ci/woodpecker/push/woodpecker Pipeline was successful
Initial commit
2024-01-05 18:10:44 +01:00

28 lines
650 B
Nix

{
description = "blog.polynom.me";
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }: flake-utils.lib.eachDefaultSystem (system: let
pkgs = import nixpkgs {
inherit system;
};
tailwindWithTypography = (pkgs.nodePackages.tailwindcss.overrideAttrs (old: {
plugins = with pkgs.nodePackages; [
"@tailwindcss/typography"
];
}));
in {
devShell = pkgs.mkShell {
buildInputs = with pkgs; [
tailwindWithTypography
zola
imagemagick
];
};
});
}